Categorias
Destaque

Lab Cisco Simples, comandos, calculo de redes e testes

Observações: Uma prática recomendada é executar o comando copy ao término de cada etapa da configuração, de forma a se manter o arquivo de configuração salvo na memória NVRAM dos dispositivos de rede. Caso esteja sendo utilizado o simulador Packet Tracer, recomenda-se, além do comando copy, que seja salvo o arquivo ao término de cada etapa de configuração. Antes de iniciar esta atividade, certifique-se de que não haja nenhuma configuração inicial nos dispositivos da topologia. Caso haja dúvidas, solicite auxílio do seu instrutor.

Parte 1: Definir as configurações básicas dos dispositivos

1.1 – Configure o hostname do roteador como R1 e do switch como SW1

> enable

# configure terminal

(config)# hostname R1

 

1.2 – Habilite a criptografia de senhas no roteador e no switch que, por padrão, não são criptografadas automaticamente na visualização da saída do comando show running-config

(config)# service password-encryption

 

1.3 – Configure o tamanho mínimo de 8 caracteres para senhas do roteador

(config)# security passwords min-length 8

 

1.4 – Configure o bloqueio de tentativas de logon no roteador, de forma a bloquear o acesso por 90 segundos, caso ocorra a falha de 3 tentativas de logon dentro de 45 segundos

(config)# login block-for 90 attempts 3 within 45

 

1.5 – Configure a senha de console como ciscoabcd e habilite o login no roteador e switch

(config)# line console 0

(config-line)# password ciscoabcd

(config-line)# login

(config-line)# exit

 

1.6 – Configure no roteador o Telnet, permitindo apenas 5 sessões, utilizando a senha cisco12345  e habilite o login. Configure o tempo de inatividade de usuários em linha de comando por acesso remoto para 4 minutos

(config)# line vty 0 15

(config-line)# session-limit 5

(config-line)# pass

(config-line)# password cisco12345

(config-line)# exec-timeout 4

(config-line)# exit

 

1.7 – Configure o SSH no switch:

1.7.1 – Domain-name: xpto.com

(config)#ip domain-name xpto.com

 

1.7.2 – Tamanho do key modulus: 1024 bits

(config)#crypto key generate rsa

 

1.7.3 – Username xyz / Secret 12345abcd

(config)# username xyz secret 12345abcd

 

1.7.4 – Permita 5 sessões

(config)# line vty 0 15

(config-line)#transport input ssh

(config-line)# session-limit 5

 

1.7.5 – Login local

(config-line)# login local

 

1.7.6 – Configure o tempo de inatividade de usuários em linha de comando por acesso remoto para 5 minutos

(config-line)# exec-timeout 5

 

1.8 – Configure a enable secret como ciscoenable no roteador e switch

 

1.9 – Configure uma mensagem de banner no roteador e switch.

 

Parte 2: Calcular as sub-redes (IPv4) necessárias
2.1 – Calcule sub-redes IPv4 a partir do endereço 192.168.1.0/24, de forma que cada uma delas
possua ao menos 40 IPs válidos
2.2 – Utilize a segunda sub-rede para endereçar a Rede Local, seguindo as regras abaixo, e
preencha a tabela:
2.2.1 – Endereço de Rede Principal: 192.168.1.0/24
2.2.2 – Endereço de Gateway: primeiro IP válido da sub-rede
2.2.3 – Endereço do Switch (vlan1): segundo IP válido da sub-rede
2.2.4 – Endereço dos PCs: penúltimo e último IPs válidos da sub-rede
2.3 – Utilize o primeiro endereço válido da terceira sub-rede para endereçar a interface Loopback
de R1

Rede Local
Loopback
End. Sub-Rede

192.168.1.0/26

Máscara

255.255.255.192

Intervalo de IPs Válidos

192.168.1.1 – 63

Broadcast

192.168.1.64

Gateway 

192.168.1.1

não se aplica
End. do Switch 

192.168.1.2

não se aplica

Parte 3: Configurar o endereçamento IPv4 nos dispositivos e interfaces

3.1 – Configure a interface Gigabit Ethernet 0/0 do roteador com o primeiro IP válido de sua subrede e habilite-a

R1>enable
R1#configure terminal
R1(config)#interface g0/0
R1(config-if)#ip address 192.168.1.65 255.255.255.192
R1(config-if)#no shutdown

3.2 – Crie e configure a interface loopback 0 do roteador com o primeiro IP válido de sua sub-rede A Loopback é uma interface virtual emulada pelo roteador para simular uma rede conectada a uma interface do equipamento, sendo que a Loopback opera, praticamente, da mesma forma que uma interface física, entretanto fisicamente não existe. Usualmente, as interfaces de Loopback são utilizadas para testes de conectividade.

R1(config)#int loopback 0
R1(config-if)#ip addr 192.168.1.129 255.255.255.192

Salvar as configurações do roteador
R1(config)#end
R1#copy running-config startup-config

3.3 – Configure o switch com o segundo IP válido da sub-rede + Endereço de Gateway

SW1>enable
SW1#conf t
SW1(config)#interface vlan 1
SW1(config-if)#ip address 192.168.1.66 255.255.255.192
SW1(config-if)#no shut
SW1(config-if)#exit
SW1(config)#ip default-gateway 192.168.1.65

3.4 – Configure os PCs com o penúltimo e último IPs válidos da sub-rede + Endereço de Gateway

3.5 – Configure uma descrição nas interfaces do roteador

R1(config)#int g0/0
R1(config-if)#description lan
R1(config-if)#int loopback 0
R1(config-if)#description wan

Salvar as configurações do Switch
R1(config)#end
R1#copy running-config startup-config

Parte 4: Configurar o endereçamento IPv6 nos dispositivos e interfaces

Utilizar Dual-Stack para configurar IPv6 nas interfaces dos dispositivos seguindo o esquema de endereçamento abaixo Rede Local End. Sub-Rede Gateway 2000:ABC::/64 2000:ABC::0

4.1 – Habilite o IPv6 no roteador

R1(config)#ipv6 unicast-routing

4.2 – Configure a interface Gigabit Ethernet 0/0 do roteador com o primeiro IPv6 válido da subrede IPv6, conforme tabela acima

R1(config)#int g0/0
R1(config-if)#ipv6 address 2000:ABC::0/64

4.3 – Configure os PCs com o segundo e terceiro IPv6 válidos de sua sub-rede + Endereço de Gateway

2000:ABC::1/64
2000:ABC::2/64

Parte 5: Testes e Verificações

5.1 – Execute o comando show ip interface brief e show ipv6 interface brief no roteador e verifique
se todas as interfaces em uso estão operacionais (Camadas 1 e 2 – OSI)
5.2 – Testes de Verificação IPv4:
5.2.1 – A partir do PC1, execute PING:
5.2.1.1 – Para o IP do PC2
5.2.1.2 – Para o IP do Switch SW1
5.2.1.3 – Para o IP do Gateway
5.2.1.4 – Para o IP da interface Loopback do roteador R1PÚBLICA
5.3 – A partir do PC1, teste a conexão SSH com o switch SW1 e a conexão Telnet com o roteador
R1:
5.4 – Testes de Verificação IPv6
5.4.1 – A partir do PC1, execute PING:
5.4.2 – Para o IP do PC2
5.4.3 – Para o IP do Gateway
5.5 – A partir do PC2, execute PING:
5.5.1.1 – Para o IP do PC1
5.5.1.2 – Para o IP do Switch SW1
5.5.1.3 – Para o IP do Gateway
5.6 – A partir do PC1, teste a conexão SSH com o switch SW1 e a conexão Telnet com o roteador
R1
5.7 – A partir do PC2, teste a conexão SSH com o switch SW2 e a conexão Telnet com o roteador
R2
5.8 – Execute o comando show adequado no roteador R1 e preencha as informações abaixo
Solicitadas:
5.8.1 – Nome do arquivo de imagem do IOS:
5.8.2 – Bytes de memória não-volátil instalada no roteador:
5.8.3 – Bytes de memória Flash instalada no roteador:
5.8.4 – Quantidade de interfaces Gigabit Ethernet existentes no roteador:
5.8.5 – Quantidade de interfaces seriais existentes no roteador:
5.9 – Execute o comando show adequado no switch SW1 e preencha as informações abaixo
solicitadas: