Leia

Pratica CCNA 3 – Aula 4– Configuração de Spanning-Tree, EtherChannel e HSRP

Configuração de Vlans => Roteamento Inter-VLAN => Etherchannel (LACP,PagP,Nenhuma) => HSRP => STP => EIGRP

Associe as interfaces FastEthernet0/23 e 0/24 ao grupo Port-Channel 1 e ative o Etherchannel manualmente utilizando o modo “on”

interface FastEthernet0/23
switchport mode trunk
channel-group 1 mode on
exit

interface FastEthernet0/24
switchport mode trunk
channel-group 1 mode on

exit

VLAN 10 (com o nome RH) na porta FastEthernet 0/1 e configure-a como modo de acesso. VLAN 20 (com o nome Compras) atribua a porta FastEthernet 0/2 e configure-a como modo de acesso.
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
exit

interface FastEthernet0/2
switchport access vlan 20
switchport mode access
exit

Na interface Port-channel 1 nos dois switches
interface Port-channel 1
switchport mode trunk
exit

Nas interfaces GigabitEthernet 0/1 nos dois switches
interface GigabitEthernet0/1
switchport mode trunk

Habilite as interfaces GigabitEthernet 0/0 dos roteadores R5 e R6. Em seguida, em cada interface GigabitEthernet 0/0, crie duas subinterfaces, uma para cada VLAN, de forma que o roteamento entre VLANs aconteça. Por fim, em cada subinterface, configure o encapsulamento DOT1Q, juntamente com o ID de VLAN, e atribua o segundo endereço IP + máscara de cada VLAN para R5 e o terceiro endereço IP + máscara de cada VLAN para R6, conforme esquema de endereçamento descrito na topologia

R5
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.2 255.255.255.0
standby 1 ip 192.168.1.1
exit

interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.0.2 255.255.255.0
standby 1 ip 192.168.0.1
exit

R6
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.3 255.255.255.0
standby 1 ip 192.168.1.1
standby 1 priority 150
standby 1 preempt
exit

interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.0.3 255.255.255.0
standby 1 ip 192.168.0.1
standby 1 priority 150
standby 1 preempt
exit

Configure as interfaces dos roteadores com os endereçamento IPv4

R1
interface Loopback0
ip address 172.16.0.1 255.255.255.0
exit

interface Loopback1
ip address 172.16.1.1 255.255.255.0
exit interface Serial0/0/0
ip address 172.16.3.2 255.255.255.0
no shutdown
exit

R2
interface Loopback0
ip address 172.16.2.1 255.255.255.0
exit

interface Serial0/0/0
ip address 172.16.3.1 255.255.255.0
no shutdown
exit

interface Serial0/0/1
ip address 172.16.6.1 255.255.255.0
no shutdown
exit

R3
interface Loopback0
ip address 172.16.5.1 255.255.255.0
exit

interface Loopback1
ip address 172.16.4.1 255.255.255.0
exit

interface Serial0/0/0
ip address 192.168.3.1 255.255.255.0
no shutdown
exit

interface Serial0/0/1
ip address 172.16.6.2 255.255.255.0
no shutdown
exit

R4
interface Serial0/0/0
ip address 192.168.3.2 255.255.255.0
no shutdown
exit

interface Serial0/0/1
ip address 192.168.2.1 255.255.255.128
no shutdown
exit

interface Serial0/1/0
ip address 192.168.2.129 255.255.255.128
no shutdown
exit

R5
interface GigabitEthernet0/0
no shutdown
exit

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.2 255.255.255.0
exit

interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.0.2 255.255.255.0
exit

interface Serial0/0/0
ip address 192.168.2.2 255.255.255.128
no shutdown
exit

R6
interface GigabitEthernet0/0
no shutdown
exit

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.3 255.255.255.0
exit

interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.0.3 255.255.255.0
exit

interface Serial0/0/0
ip address 192.168.2.130 255.255.255.128
no shut
exit

Defina o root bridge para a VLAN10 (SW1) e VLAN20 (SW2). Configure como root bridge alterando manualmente a prioridade do switch para 4096
SW1 => spanning-tree vlan 10 priority 4096
SW2 => spanning-tree vlan 20 priority 4096

No roteador R6 defina, em cada subinterface, o endereço IP virtual de cada uma das VLANs e altere sua prioridade para 150 para que ele seja o roteador ativo. Habilite o Preemption em R6, para forçar uma nova eleição caso R6 fique ativo (UP) após já ter ocorrido a eleição do Active Router
R6
interface GigabitEthernet0/0.10
standby 1 ip 192.168.1.1
standby 1 priority 150
standby 1 preempt
exit

interface GigabitEthernet0/0.20
standby 1 ip 192.168.0.1
standby 1 priority 150
standby 1 preempt
exit

No roteador R5 defina, em cada subinterface, o endereço IP virtual de cada uma das VLANs
R5
interface GigabitEthernet0/0.10
standby 1 ip 192.168.1.1
exit

interface GigabitEthernet0/0.20
standby 1 ip 192.168.0.1
exit

No roteador R1.
Habilite o protocolo OSPF.
Defina o router ID como 1.1.1.1
Declare as três Redes conectadas à Área 1
Declare as interfaces loopback como passivas
router ospf 1
router-id 1.1.1.1
passive-interface Loopback0
passive-interface Loopback1

No roteador R2:
Habilite o protocolo OSPF
Defina o router ID como 2.2.2.2
Declare as duas Redes conectadas à Área 1
Declare a Rede conectada à Área 0
Declare as interfaces loopback como passivas
Faça a sumarização manual das redes da Área 1
router ospf 1
router-id 2.2.2.2
passive-interface Loopback0
area 1 range 172.16.0.0 255.255.252.0
network 172.16.6.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 1
network 172.16.3.0 0.0.0.255 area 1

No roteador R3:
Habilite o protocolo OSPF
Defina o router ID como 3.3.3.3
Declare as duas Redes conectadas à Área 2
Declare a Rede conectada à Área 0
Declare as interfaces loopback como passivas
Faça a sumarização manual das redes da Área 2
router ospf 1
router-id 3.3.3.3
area 2 range 172.16.4.0 255.255.254.0
passive-interface Loopback0
passive-interface Loopback1
network 172.16.4.0 0.0.0.255 area 2
network 172.16.5.0 0.0.0.255 area 2
network 172.16.6.0 0.0.0.255 area 0

No roteador R3:
Habilite o protocolo EIGRP
Desabilite a sumarização automática
Declare a Rede do enlace serial diretamente conectada em s0/0/0
router eigrp 1
network 192.168.3.0
exit

No roteador R4:
Habilite o protocolo EIGRP
Desabilite a sumarização automática
Declare as três Redes dos enlaces seriais diretamente conectadas
router eigrp 1
network 192.168.3.0
network 192.168.2.0 0.0.0.127
network 192.168.2.128 0.0.0.127

No roteador R5:
Habilite o protocolo EIGRP
Desabilite a sumarização automática
Declare as três Redes diretamente conectadas
Declare a interface que se conecta à rede local como passiva
router eigrp 1
passive-interface GigabitEthernet0/0
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0 0.0.0.127

No roteador R6:
Habilite o protocolo EIGRP
Desabilite a sumarização automática
Declare as três Redes diretamente conectadas
Declare a interface que se conecta à rede local como passiva
router eigrp 1
passive-interface GigabitEthernet0/0
network 192.168.0.0
network 192.168.1.0
network 192.168.2.128 0.0.0.127

No roteador R3, no processo do OSPF. Configure a redistribuição das rotas do EIGRP com métrica 100
router ospf 1
redistribute eigrp 1 metric 100 subnets

No roteador R3, no processo do EIGRP:
Configure a redistribuição das rotas do OSPF com os seguintes valores:
Bandwidth = 1GB
Delay = 10us
Reliability = 255
Load = 1
MTU = 1500
router eigrp 1
redistribute ospf 1 metric 1000 10 255 1 1500